본문내용 바로가기 메인메뉴 바로가기 푸터 바로가기

보안공지

Discourse 오픈소스 플랫폼 보안 업데이트 권고2021.10.27
□ 개요
 o Discourse社는 자사 제품에서 발생하는 보안 취약점에 대한 보안 업데이트 발표
 o 공격자는 취약점을 악용하여 원격코드실행 등의 피해를 발생시킬 수 있으므로, 영향받는 제품을 이용 중인 사용자는 최신버전으로 보안 업데이트 권고
  * Discourse : 오픈소스 기반의 커뮤니티 플랫폼
 
□ 설명
 o Discourse 라이브러리에서 파라미터에 대한 검증이 미흡하여 발생하는 원격코드실행 취약점(CVE-2021-41163) [1]
 
□ 영향받는 버전 및 해결 버전
유형 영향받는 버전 해결 버전
안정화(Stable) 버전 2.7.8 및 이전 버전 2.7.9 이상 버전
임시(Beta) 버전 2.8.0.beta6 및 이전 버전 2.8.0.beta7 이상 버전
tests-passed 버전
 
□ 해결 방안
 o 최신버전으로 업데이트 수행
  ※ 참고사이트[1]의 commit 버전을 참고하여 패치 적용
 
□ 기타 문의사항
 o 한국인터넷진흥원 사이버민원센터: 국번없이 118
 
[참고사이트]
[1] https://github.com/discourse/discourse/security/advisories/GHSA-jcjx-pvpc-qgwq


□ 작성 : 침해사고분석단 취약점분석팀